Issue with receiving support requests
Incident Report for imgix
Resolved
We have fixed the support@imgix.com email address and are processing our backlog of support requests. If you sent an email and have not received a reply until today, please reach back out to us through our contact form: https://dashboard.imgix.com/contact
Posted Nov 06, 2024 - 13:29 PST
Identified
We have identified an issue with receiving support requests to support@imgix.com and are working on a fix. In the meantime, please use our contact form to reach support: https://dashboard.imgix.com/contact
Posted Nov 06, 2024 - 09:47 PST